(Opticodec-PC Streaming Audio Streaming Encoder)

Orban Opticodec-PC v2.0
Streaming Audio Encoder

05-2005

Help Topics

  • Configuration


(Opticodec-PC Configuration)

Opticodec-PC v2.0 Encoder Configuration

  • Sound Device

  • Encoding Parameters

  • Destination Server

  • Stream Description

  • Metadata

  • Encode / Stop


(Opticodec-PC Configuration - Sound Device)

Sound Device

Sound Device selects the Windows sound device that will provide audio input to Optocidec-PC.

On Opticodec-PC LE, this selects any installed Windows Recording Sound Device.

On Opticodec-PC SE, only the sound device from Windows SoundMapper (the default Windows Recording Sound Device) is supported.

On Opticodec-PC PE , only Orban Optimod 1100 is supported.


(Opticodec-PC Settings - Encoding Parameters)

Encoding Parameters

    Orban Opticodec-PC uses genuine Coding Technologies AAC/aacPlus - the most efficient audio codec available. To fully exploit this efficiency, and obtain the best possible audio quality, source audio should be encoded as linear PCM, or at worst, MPEG1 Layer 2 at 256kbps or higher, or AAC at 128kbps or higher.

    Transcoding from other inferior audio codecs such as MPEG1 Layer 3 (MP3) or Windows Media Audio (WMA) to AAC/aacPlus can produce audible artifacts and will not reveal all the benefits of Opticodec-PC.

  1. Sound Device

    Sets the source audio device.

    PE - Orban 1100 Optimod-PC
    SE - WaveMapper (Windows Default Recording Sound Device)
    LE - Any Windows Sound Recording Device

  2. Bit Rate

    Sets the data rate. This determines the audio quality that will be served to the intended audience.

  3. Sample Rate

    Sets the audio sample rate. This should either be set to match the source audio or audio files or should be set lower.

    Certain bit rates will benefit from lower sample rates than the source sample rate, resulting in better high frequency response. Refer to the codec parameters to determine this.

    Upsampling or setting the sample rate higher than the input rate is not recommended. This does not improve quality because the original source determines the audio bandwidth.

  4. Encoder

    AAC / HE AAC /aacPlus

    AAC mode is recommended for bit rates of 128 kbps and higher.
    HE AAC/aacPlus is recommended for bitrates below 128 kbps

  5. Channel

    Mono / Stereo / Stereo v2 (PS)

    Mono/Stereo is supported by all AAC/HE AAC/aacPlus client players.
    Stereo v2 (PS) is currently only supported by Nullsoft Winamp.
    Stereo v2 (PS) is recommended for bitrates below 48 kbps.
    Stereo v2 (PS) will play in Mono using a player that does not support it.

  6. Optimize

    Default / Voice

  • Use Default for mixed speech and music source audio.
  • Use Voice for source audio that is exclusively speech.

CLICK APPLY AFTER MAKING ANY CHANGES ON ANY SETTINGS PAGE.


(Opticodec-PC Configuration - Stream Description)

Stream Description

  1. Name
    Enter the Stream Name to display in compatible player clients.

  2. Description
    Enter the Stream Description to display in compatible player clients.

  3. Title
    Enter the Metadata Title Field to display in compatible player clients.

  4. Genre
    Enter the Metadata Genre to display in compatible directory list servers.


(Opticodec-PC Configuration - Destination Server)

Destination Server

  1. Server

    Choose from the following Server protocols:

    RTSP/RTP - Unicast (Remote)
    Darwin Streaming Server / QuickTime Streaming Server

    RTSP/RTP - Unicast (Local)
    Internal Streaming Server - Player(s) connect(s) directly to Encoder using the URL specified in the Encoder. There is an 8 player client limit.

    RTSP/RTP - Multicast
    Internal Multicast Streaming Server - Player(s) connect via Multicast enabled network using .sdp file created by Encoder in application directory.

    HTTP/ICY - SHOUTcast (aac)
    SHOUTcast DNAS using a Content Type of audio/aac. This can be used for either AAC or aacPlus streams.

    HTTP/ICY - SHOUTcast (aacp)
    SHOUTcast DNAS using a Content Type of audio/aacp. This can be used for either AAC or aacPlus streams. This Content Type will list on the SHOUTcast Stream Directory if Stream Directory Listing is enabled.

    HTTP/ICY - Icecast2
    Icecast2 Streaming Server 2.2.0 and higher. This uses a Content Type of audio/aac.

    HTTP/UVOX - Ultravox 3
    Ultravox 3 Firehose Server

  2. RTP

    Choose from the following RTP Packet formats:

    MPEG - Streaming to normal network computers and devices.
    LATM - Streaming to 3GPP mobile devices (PE Version only).

  3. URL

    Enter the IP address or domain name of Streaming Server. This IP address or domain name must contain the characters rtsp://, http://, or uvox://, depending upon type of server.

    Examples:
    rtsp://10.0.0.1
    http://stream.network.com

  4. Port

    Sets the Port number of Streaming Server used.
    The Port Number must be configured at the Server.
    For Multicast, the Port number must be between 6000 and 65535.

    Examples:
    554
    6000
    8000
    80

  5. TTL

    Sets Time to Live (TTL).
    This specifies how many routers or hops that the Multicast traffic is permitted to pass through before expiring on the network, or how far the Multicast will travel.
    If the TTL value is set too high, Multicast streams may travel too far, creating unnecessary network traffic, and may be available where not intended.

    Examples:
    0 - Host - Restricted to the same host. Will not be output by any interface.
    1 - Local - Restricted to the same subnet. For links in a single network segment.
    16 - Company - For links that separate sites within an organization.
    32 - Enterprise - For links that separate organizations.
    64 - Country - For links that separate countries or regions.
    128 - World - For links that separate continents.
    255 - Global - Unrestricted in scope.

  6. Filename

    [For a SHOUTcast server, this field is not used.]
    For RTSP/RTP Servers, provide the name of the .sdp file.
    For HTTP/ICY Icecast2 Servers, provide the name of the mountpoint.
    For HTTP/UVOX Servers, provide the name of the SID.

    The filename or mountpoint:
    - must not contain spaces.
    - must end with a .sdp extension for RTSP Servers.
    - may contain directory paths.
    - may contain .aac extension for Icecast2 Servers.

    Examples:

    Darwin/QuickTime Streaming Server
    stream.sdp
    content/stream.sdp

    Icecast2 Server
    stream
    stream.aac

    Ultravox 3 Firehose Server
    stream

  7. User

    If you are using a RTSP/RTP Streaming Server, enter the Server Encoder Username. This must be configured at the Server.

  8. Pass

    Enter the Server Encoder Password for the Streaming Server. This must be configured at the Server.

  9. Website URL

    Enter the stream associated Website URL if any. This will show in some players and be listed on any configured Stream Directories. If a stream associated Website URL does not exist, leave this field empty.

    Example:
    http://www.orban.com

  10. Enable Stream Directory Listing

    Enables Stream Directory Listing for SHOUTcast and Icecast2 compatible Stream Directories.

    Examples:

    http://www.shoutcast.com
    http://dir.xiph.org/index.php
    http://www.steamcast.com
    http://www.radiotoolbox.com/dir

  11. Connect on Start

    Automatically connect Encoder to Server when Encoder is started.


(Opticodec-PC Configuration - Start/Stop)

Encode / Stop

  1. Encode

    Click Encode. This will:

    - Start the Encoder.
    - Authenticate the Encoder with the streaming server.
    - If using RTSP/RTP Unicast, send the .sdp file to the streaming server.
    - If using RTSP/RTP Multicast, send the .sdp file to the local application directory.
    - Initiate streaming.

  2. Stop

    Click Stop. This will:

    - Stop the Encoder.
    - If using RTSP/RTP Unicast, the .sdp file on the streaming server will be removed from the server after expiration time specified by the streaming server configuration.
    - If using RTSP/RTP Multicast, the .sdp file in the local application directory will be removed immediatley.
    - Terminate streaming.

  3. Saving and Loading Settings

    After configuring the Encoder, the current Encoder Settings may be saved. In the File Menu, select Save Settings, name the file, and click Save.

    The Encoder Settings may be loaded from saved Settings Files. In the File Menu, select Load Settings, select the Settings File to be loaded, and click Open.

  4. Command-Line / Batch-File Execution

    The Encoder may be started from command-line or batch-file execution.

    Command-line syntax:

    opticodec-pc_le -file settingsfile.opcpes
    opticodec-pc_se -file settingsfile.opcpes
    opticodec-pc_pe -file settingsfile.opcpes
    If a settings file is not specified, the Encoder Settings from the last encoding session will be used by default.

    It is necessary to enable Connect on Start for the Encoder to start from command-line or batch-file execution.

    More than one encoder may be started from a batch-file with different settings files.

    A batch-file may be placed in the appropriate Startup directory to automatically start the Encoder upon Windows boot.


(Opticodec-PC Configuration - Metadata)

Metadata

    HTTP/ICY streams only.

  1. Enabled
    Enables/Disables streaming metadata.

  2. File
    Reads a single-line text file in 15 second intervals for streaming metadata display.
    Recomended format: Artist - Title
    File location is user specified.

  3. Winamp Source
    Reads Winamp Artist-Title information in 15 second intervals for streaming metadata disply. Winamp must be run as the audio source on the same computer as Opticodec-PC.

  4. Serial Port
    Reads serial port ASCII for real-time streaming metadata display.
    Port Parameters: 9600-N-8-1
    Data Format: Field=Value Delimiter: ^

    Example: ARTIST=artist^TITLE=title
    Not case or sequence sensitive.

  5. Ethernet/TCP - NexGen
    Reads Ethernet port for real-time streaming metadata display sourced from Prophet Systems NexGen Digital Playout System.

  6. HTTP - OtsDJ
    Reads OtsDJ Artist-Title information from OtsDJ HTTP server in 15 second intervals for streaming metadata display. URL is user specified.

  7. Opticodec-PC Local Broadcast
    (PE/SE version only)
    Reads streaming metadata from another Opticodec-PC encoder running on the same computer. Useful for multiple streams of the same program.

  8. Enable Local Broadcast
    (PE/SE version only)
    Enables streaming metadata to be broadcast to other Opticodec-PC encoders running on the same computer.


(Opticodec-PC Configuration - Codec Parameters)

Codec Parameters

aacPlus Configurations

aacPlus Mode | Channel Mode | Bitrate [kbps] | Sample Frequency [kHz] | Audio Bandwidth [kHz]
aacPlus | 1ch-Mono | 8 | 24 | 8.3
aacPlus | 1ch-Mono | 10 | 24, 32 | 10.9, 11.0
aacPlus | 1ch-Mono | 12 | 24, 32, 44.1 | 11.4, 11.0, 10.7
aacPlus | 1ch-Mono | 16 | 32, 44.1, 48 | 12.3, 11.7, 12.0
aacPlus | 1ch-Mono | 20 | 32, 44.1, 48 | 14.5, 14.8, 15.4
aacPlus | 1ch-Mono | 24 | 32, 44.1, 48 | 15.3, 14.8, 15.4
aacPlus | 1ch-Mono | 28 | 32, 44.1, 48 | 16.0, 16.2, 16.9
aacPlus | 1ch-Mono | 32 | 32, 44.1, 48 | 16.0, 16.2, 16.9
aacPlus | 1ch-Mono | 40 | 32, 44.1, 48 | 16.0, 17.6, 18.4
aacPlus | 1ch-Mono | 48 | 32, 44.1, 48 | 16.0, 20.3, 20.3
aacPlus | 1ch-Mono | 56 | 32, 44.1, 48 | 16.0, 20.3, 20.3
aacPlus | 1ch-Mono | 64 | 32, 44.1, 48 | 16.0, 20.3, 20.3
aacPlus | 2ch-Stereo | 24 | 32, 44.1, 48 | 13.8, 12.7, 13.1
aacPlus | 2ch-Stereo | 28 | 32, 44.1, 48 | 15.3, 14.8, 15.4
aacPlus | 2ch-Stereo | 32 | 32, 44.1, 48 | 15.3, 14.8, 15.4
aacPlus | 2ch-Stereo | 40 | 32, 44.1, 48 | 16.0, 16.2, 16.9
aacPlus | 2ch-Stereo | 48 | 32, 44.1, 48 | 16.0, 16.2, 16.9
aacPlus | 2ch-Stereo | 56 | 32, 44.1, 48 | 16.0, 17.6, 18.4
aacPlus | 2ch-Stereo | 64 | 32, 44.1, 48 | 16.0, 20.3, 22.1
aacPlus | 2ch-Stereo | 80 | 32, 44.1, 48 | 16.0, 20.3, 22.1
aacPlus | 2ch-Stereo | 96 | 32, 44.1, 48 | 16.0, 20.3, 22.1
aacPlus | 2ch-Stereo | 112 | 32, 44.1, 48 | 16.0, 20.3, 22.1
aacPlus | 2ch-Stereo | 128 | 32, 44.1, 48 | 16.0, 20.3, 22.1

AAC Configurations

AAC Mode | Channel Mode | Bitrate [kbps] | Sample Frequency [kHz] | Audio Bandwidth [kHz]
AAC | 1ch-Mono | 16 | 24 | 5.2
AAC | 1ch-Mono | 20 | 24 | 7.2
AAC | 1ch-Mono | 24 | 24, 32 | 7.2, 7.2
AAC | 1ch-Mono | 28 | 24, 32 | 10.0, 10.0
AAC | 1ch-Mono | 32 | 24, 32, 44.1, 48 | 10.0, 10.0, 10.0, 10.0
AAC | 1ch-Mono | 40 | 24, 32, 44.1, 48 | 12.0, 12.4, 12.4, 12.4
AAC | 1ch-Mono | 48 | 24, 32, 44.1, 48 | 12.0, 13.5, 13.5, 13.5
AAC | 1ch-Mono | 56 | 24, 32, 44.1, 48 | 12.0, 15.5, 15.5, 15.5
AAC | 1ch-Mono | 64 | 32, 44.1, 48 | 15.5, 15.5, 15.5
AAC | 1ch-Mono | 80 | 32, 44.1, 48 | 16.0, 17.6, 17.6
AAC | 1ch-Mono | 96 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 1ch-Mono | 112 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 1ch-Mono | 128 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 1ch-Mono | 160 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 2ch-Stereo | 24 | 24 | 6.6
AAC | 2ch-Stereo | 28 | 24 | 6.6
AAC | 2ch-Stereo | 32 | 24 | 6.6
AAC | 2ch-Stereo | 40 | 24, 32 | 8.5, 8.5
AAC | 2ch-Stereo | 48 | 24, 32 | 8.5, 8.5, 8.5
AAC | 2ch-Stereo | 56 | 24, 32, 44.1, 48 | 12.0, 12.5, 12.5, 12.5
AAC | 2ch-Stereo | 64 | 32, 44.1, 48 | 12.5, 12.5, 12.5
AAC | 2ch-Stereo | 80 | 32, 44.1, 48 | 13.5, 13.5, 13.5
AAC | 2ch-Stereo | 96 | 32, 44.1, 48 | 15.5, 15.5, 15.5
AAC | 2ch-Stereo | 112 | 32, 44.1, 48 | 16.0, 16.0, 16.0
AAC | 2ch-Stereo | 128 | 32, 44.1, 48 | 16.0, 16.0, 16.0
AAC | 2ch-Stereo | 160 | 32, 44.1, 48 | 16.0, 17.6, 17.6
AAC | 2ch-Stereo | 192 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 2ch-Stereo | 224 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 2ch-Stereo | 256 | 32, 44.1, 48 | 16.0, 22.1, 24.0
AAC | 2ch-Stereo | 320 | 32, 44.1, 48 | 16.0, 22.1, 24.0

Note: Not all Codec Configurations are available in Opticodec-PC LE.


(Opticodec-PC Configuration - Intended Audience)

Sample Rate for Intended Audience

Connection Speed | Bitrate Safe | Bitrate Maximum
3GPP Mobile Streaming | 16kbps | 24kbps
Dial-Up 28.8kbps Modem | 16kbps | 24kbps
3GPP Mobile Streaming | 24kbps | 32kbps
Dial-Up 56kbps Modem | 32kbps | 40kbps
3GPP Mobile Streaming | 32kbps | 40kbps
Single ISDN 64kbps | 48kbps | 56kbps
Dual ISDN 128kbps | 80kbps | 96kbps
DSL 256kbps | 128kbps | 160kbps
DSL 512kbps | 256kbps | 384kbps
DSL 1.5Mbps | 256kbps | 384kbps
Cable Modem | 256kbps | 384kbps
Corporate LAN | 128kbps | 384kbps